Android Studio 工程多个不同版 support-v4 包引起的错误

所报的错误可能是:

UNEXPECTED TOP-LEVEL EXCEPTION
multiple dex files define Landroid/support/annotation/AniRes

原因:使用了多个不同版本的 support-v4

解决方案:

modulebuild.gradledependency 添加依赖时,加入 exclude 规则:

compile ('com.bugtags.library:bugtags-lib:latest.integration'){
        exclude group: 'com.android.support', module: 'support-v4'
}